Links

Compatibility

Integrating Cypress with Currents - compatibility table
We are suspending our support of Cypress test runner version 13+
We will continue to support prior versions of Cypress.
Read more
We provide several packages to integrate cypress runner with Currents (or Sorry Cypress) orchestration services:
  • ☁️ cypress-cloud - standalone runner for Sorry Cypress and Currents
  • [deprecated] cy2 - package for integrating arbitrary cloud orchestration services with cypress
  • [deprecated] @currents/cli - a dedicated package for integrating cypress with Currents cloud service
Please use the table below to select the version of the compatible package.

Currents Customers

Cypress Version
@currents/cli [deprecated]
cypress-cloud
13.2.0+
not supported
not supported
not supported
2.0.0-beta.1+
12.6.0+
not supported
1.4.1+
12.1.0+
4.0.3+
1.4.1+
12.0.0+
3.1.3+
1.4.1+
11.0.0+
3.0.0+
1.4.1+
6.7.0+
any version
not supported

Sorry Cypress Users

Cypress Version
cy2 [deprecated]
cypress-cloud
13.2.0+
not supported
not supported
not supported
2.0.0-beta.1+
12.6.0+
not supported
1.4.1+
12.1.0+
4.0.6+
1.4.1+
11.0.0+
4.0.1+
1.4.1+
6.7.0+
any version
not supported

NX Users

NX users can use @currents/nx plugin to conveniently integrate Currents or Sorry Cypress with their project
Cypress
@currents/nx
12.6.0+
2.0.0+
12.1.0+
2.0.0+
12.0.0+
0.2.1+
11.0.0+
0.1.0+
6.7.0+
any version